Using Mosaic and the Internet:
An Interactive Guide for Junior High Students

Wanda Chiu, Juris A. Grasis, Patrick T. Homer, David K. Lowenthal, and
Jennifer A. Schmitt

TR 95-06

Abstract

Computer Capers is an annual outreach program conducted at The University of Arizona, Department of Computer Science. Each June, 50 junior high kids attend one of two, one-week sessions. For 1994 and 1995, the curriculum has focused on the Internet and the use of Mosaic and associated tools. These lessons were developed for this course in May 1994, revised and updated in May 1995, and tested during Capers each year. They are being made available in a variety of formats {html, postscript, hard copy, FrameMaker} in the hope that they may prove useful to others.

The lessons have two main goals. The first is to familiarize students with Mosaic and its supporting tools on Macintosh computers so the students can explore the World Wide Web. The second goal is to encourage students to develop their own home pages, learning the basics of HTML and how to include pictures, sounds, movies, and links.

The first two lessons provide an introduction to using the Macintosh. Lessons three through seven cover the use of Mosaic and its principal support tools: JPEGView, MoviePlayer, Sparkle and Sound Machine. Lesson eight provides some starting points for net surfing, including a number of sites to explore. Finally, lessons nine and ten cover designing and writing home pages.

July 7, 1995

Department of Computer Science
The University of Arizona
Tucson, Arizona 85721
Copyright Notice

This material was developed by The University of Arizona, Department of Computer Science. Permission to copy these lessons, to redistribute them, and to use them for any purpose is granted, subject to the following restrictions and understandings:

1. Any copy made of the lessons must include this copyright notice in full.

2. Users of the lessons agree to make their best efforts to inform the department of noteworthy uses of this material.

3. All materials developed as a consequence of the use of these lessons shall duly acknowledge such use, in accordance with the usual standards of acknowledging credit in academic research.

4. The University of Arizona has made no warrantee or representation that these lessons are error-free, and the University is under no obligation to provide any services, by way of maintenance, update, or otherwise.

5. In conjunction with any products arising from the use of this material, there shall be no use of the name of The University of Arizona nor of any adaptation thereof in any advertising, promotional, or sales literature without prior written consent from the University in each case.

Additional Information

Comments, Suggestions, Questions, and Bugs can be sent to:
Patrick T. Homer
Department of Computer Science
University of Arizona
Tucson, AZ 85721
email: patrick@cs.arizona.edu

This material is also available in the following formats:
World Wide Web: http://www.cs.arizona.edu/
# Table of Contents

Unit 1: Introduction to the Macintosh .............................................. 7  
  Menu Bar: ................................................................. 7  
  Scroll Bar: ............................................................. 9  
  Application Menu: ..................................................... 9  
  Selecting Applications, Windows, and the Desktop: ...................... 10  
  Disks and Files: ......................................................... 11  
  Getting Help: ............................................................. 12

Unit 2: Using Simple Text .............................................................. 15  
  Starting Simple Text: .................................................... 15  
  Getting Help: ............................................................. 15  
  Basic Text Editing: ....................................................... 15  
  Cut, Copy, and Paste: .................................................... 16  
  Fancy Text: ............................................................... 17  
  Saving Files: ............................................................. 17  
  Opening Files: ........................................................... 19

Unit 3: Mosaic Introduction ............................................................. 21  
  Mosaic Controls: .......................................................... 21  
  Beginning Navigation: ..................................................... 23  
  Some Menu Options: ...................................................... 25  
  Helper Applications: ....................................................... 25  
  Getting Help: ............................................................. 26  
  Cloning Windows: ........................................................ 26

Unit 4: JPEGView ......................................................................... 29  
  Getting Help: ............................................................. 29  
  Experimenting with Sizes: .................................................. 29  
  Selecting, Cropping, and a Slide Show: .................................... 31  
  Other Things to Try: ...................................................... 32

Unit 5: Movie Player ...................................................................... 35  
  Getting Help: ............................................................. 35  
  Playing the Movie, Basic Controls: ....................................... 35  
  Re-sizing and Some Other Effects: ....................................... 36  
  Selecting and Editing: ..................................................... 36  
  Other Things to Try: ...................................................... 37

Unit 6: Sparkle ............................................................................ 39  
  Getting Help: ............................................................. 39  
  Playing the Movie, Basic Controls: ....................................... 39  
  Creating a Faster Movie: .................................................. 40  
  Other Things to Try: ...................................................... 41
Unit 7: Sound Machine ........................................ 43
  Getting Help: ............................................... 43
  Playing the Sound, Basic Controls:  ..................... 43
  Queues of Sounds: ........................................ 44
  Other Things to Try: ...................................... 44

Unit 8: Net Surfing ........................................... 45
  Beginning Net Surfing: .................................... 45
    URL: ....................................................... 45
  Go Adventuring!: ........................................ 46
    Places to Explore: ....................................... 47
    Searchable Mosaic Sites: ................................. 50
  Other Sites to Try: ........................................ 51
  Remembering Where You’ve Been: ......................... 52
    Editing the Hotlist: ..................................... 54
    Hotlist Full?: .......................................... 54
  Can I Speed Things Up? ................................... 54
    Stopping a Transfer ..................................... 55
    Capturing Files ......................................... 55

Unit 9: Designing Mosaic Documents ......................... 57
  A Brilliant Idea! .......................................... 57
    Fanciful Dreams: ....................................... 58
    Adventuring: ........................................... 58
  Including Things: ........................................ 58
    Where to Go From Here: ................................. 58

Unit 10: Writing Mosaic Documents .......................... 61
  Write, Save, View Cycle: ................................ 61
  HyperText Markup Language(HTML): .................... 61
  Basic Formatting: ........................................ 61
    Headings: ................................................ 62
    Paragraphs: ............................................. 62
    Title: ..................................................... 63
    Text Styles: ............................................. 63
  Links and Anchors: ....................................... 63
    File Locations: ......................................... 64
    URL: ..................................................... 65
  Links to the Middle of Documents: ....................... 66
  Links to Other Types of Documents: ..................... 67
  In-lining Images: ......................................... 67
    Acquiring Small Images: ................................. 68
  More Formatting: ......................................... 68
    Lists: .................................................... 68
    Preformatted Text: ...................................... 70


**Unit 1: Introduction to the Macintosh**

When using the Macintosh, you will use both the keyboard and the mouse to give instructions and commands. The mouse controls the *cursor*, the small arrow on the screen. When you move the mouse, the cursor moves as well.

There is a button on the mouse that can be used in three basic ways:

- **click**: press and release the mouse button
- **drag**: press the mouse button and hold it down while moving the mouse
- **double-click**: two clicks in quick succession

**Menu Bar:**

Let’s start with the menu bar, the list of words and symbols that appears across the top of the Macintosh screen. The menu bar is (almost) always visible when using the Mac; although, you will notice that its contents will change depending on what program you are using. A sample menu bar is shown below. The menu bar on your screen should be very similar (the date and time, for example, will be different and some of the items will be in color).

```
16 File Edit View Label Special Tue 4:34:13 PM
```

The menu bar contains commands that can be given to the Mac. To explore a little, try pointing the mouse at the Apple menu on the left side of the menu bar. Now, hold down the mouse button. A *pull down menu* will appear. If you now *drag* the mouse (move the mouse while pressing the button), you will see each item in the menu light up in succession as the mouse pointer moves down the list.

To select one of the items, just release the mouse button when that item is highlighted. For example, try selecting the *Calculator* item. This will start a program that will display a calculator on the screen. It may take a few seconds
You can use the mouse to point at and “push” the buttons on the calculator. Try clicking with the mouse on the various keys on the calculator. As long as the calculator is up, you can also try using either set of keys on the keyboard. The last thing to notice is the menu bar — it has changed and now only shows the Apple menu and the words File and Edit on the left side. The right side is also different, as a miniature calculator symbol, ☐, has replaced the Finder symbol (Finder) that was there before.

You can move the Calculator to a different place on the screen. Point anywhere in the Title bar except in the Close box. Hold down the mouse button and drag the mouse. An outline of the Calculator window will follow the cursor around the screen. When you release the mouse button, the Calculator will jump to its new location on the screen. This technique can be used with any Mac window that has a Title bar. It is a useful way to keep windows, or portions of windows, visible on the screen.

When you are done with the Calculator, there are two ways to close it. One is to click the Close button on the Calculator’s upper left corner. The other is to point to the File menu, then drag down to the Quit item. What you can do is close the Calculator using one of the methods, then open the Calculator again (remember how?) and use the other method to close it.

If you now open the Calculator again, notice two things. First, the Calculator application remembers where you last had it positioned on the screen and returns to that same place. Second, any value that was displayed in the Calculator’s Display when it was closed will still be in the Display when the Calculator is started again.
Scroll Bar:

Try out some of the other items in the Apple menu; such as the Alarm Clock, Puzzle, and Scrapbook items. Each of these has slightly different controls, but there are similarities to the Calculator. For example, each has a title bar at the top with a close box on the left side of the title bar. See if you can figure out the other controls! Here’s one hint: Open the Scrapbook. You will find a *scroll bar* near the bottom of the window as shown below:

![Scroll Bar Diagram]

Try clicking on the Right arrow and the Left arrow. The picture displayed above the scroll bar will change, and the Thumb will move to the right or left. The Thumb represents your relative position between the first and last item in the scrapbook.

Next, try clicking on the scroll area, either to the right or the left of the Thumb. This has the same effect as clicking on the Left or Right arrow — you should jump to the next picture. Finally, you can *drag* the Thumb to move it. When you release the mouse button, the Thumb will remain near its new position and the Scrapbook will jump to that item.

Scroll bars appear in many situations on the Macintosh. Some of them will be horizontal as in this example, usually appearing at or near the bottom of a window. Others will be vertical and used to move up and down through a list, picture, etc. Typically, the vertical scroll bars will be at or near the right side of a window.

Application Menu:

To see how to use the Application menu, you will need a program running, so select one of the items from the Apple menu. The Application menu will change from the small computer shape that represents the Finder ( ) to a small shape that represents the program you have running, such as the small calculator shape ( ) that was present when running the Calculator. Point the mouse at the Application menu and hold down the mouse button. You will see a menu that lists the applications, or programs, that you currently have
running. The Finder will always be on the list, and others will be as well from time to time. You can drag down to one of the programs to select it. That program will then come to the front of the screen and become the active program. The program which was in the front will disappear from the screen but is not gone. It is in the background. You can add more applications to the list simply by starting them from the Apple menu. They disappear from the list when they are Quit.

The top part of the menu controls whether the windows of background programs are visible or hidden. You normally won’t want them to show, since they tend to clutter up the screen. If you select Show All, you will see all the windows of all the applications. Of course, some of them will be behind others. The active application always has its window in front.

Selecting Applications, Windows, and the Desktop:

For this section, you will need to start more than one application. So, start the Calculator, then start the Puzzle, and finally start the Scrapbook. In each case, don’t Close or Quit the previous one, just go to the Apple menu and start each one. Finally, go to the Application menu and pull it down. Notice that there are four items listed at the bottom of the menu: Finder and the other three applications.

There are two points to make here first. You can, of course, change among the various applications by selecting the one you want from the Application menu. However, you can also select the item from the Apple menu. When you, for example, select the Calculator from the Apple menu, you do not get another Calculator, the Mac simply brings the Calculator you already have running to the front and makes it the active window.

Now, select Show All in the Application menu. You should now have all three windows visible. With all the applications visible, you can switch from one to another by just clicking on the window you want to become the active window. Give it a try!

The Finder uses the concept of a desktop. This refers to the space on the screen below the menu bar. If you imagine it as a horizontal surface, then the icons on the right, and the windows of applications that may be open, can be thought of as lying on a desktop. When you select a background application, it is like moving a book or some papers to the top of the other items on the desktop. You can select the Finder by clicking on the desktop. When you do this, the Finder, , comes to the “front” and is now the active application. The application that was in front has not stopped, it is switched to the
background exactly as would happen when you select Finder from the Application menu. You can get back to your application by using the Application menu.

**Disks and Files:**

You may have noticed that we have been ignoring those pictures on the right side of the screen. They represent the disk, or disks, the computer can access. Each disk holds applications and data files. The applications are similar to the ones you have been using under the Apple menu and they could have all been listed under that menu. However, the list would be too long and cumbersome to manage. The data files are each associated with one application and contain information that is either used by the application, or was written by the application, or both.

To see what is on the disk, you need to open the icon for the disk on your machine. This is the icon that looks like:

```
.
```

Poodle-228

The name underneath the disk icon corresponds to the name of the Mac.

To see what applications and data files are on your Mac, you need to open the disk. This can be done in two ways. For the first method, point the mouse at the picture of the disk or the name underneath it and click the mouse. It will change color to something like:

```

```

Poodle-228

This indicates it is the currently selected object. Now, move to the File menu on the menu bar, and drag down the menu to the Open item and select it. The disk icon will open out into a window that shows the files and applications that are contained on the disk. The second method of opening an item is to *double-click* it. This does not require the use of the File menu.
A sample window is shown below:

The grow box in the lower right corner can be used to change the size of the window. With the cursor pointing at the grow box, drag the mouse to make a larger or smaller window. When you release the mouse button, the window will jump to the new size.

Generally, a computer has too many files and applications to be able to show all of them in one window. The Mac uses folders ( ) to contain collections of applications, files, and other folders. To see this, open the folder named “Capers” that is on your disk. Try opening other folders to explore what is inside each. You can close a window by clicking on the close box of the window, or by choosing Close Window from the File menu.

Getting Help:

There are two sources of help. One is balloon help. This can be turned on by selecting Show Balloons under the Help menu ( ). The second source of help, which is specific to each application, is also selected using the Help
These help items are located below the Show Balloons under the Help menu. Not all applications support both forms of help. The Finder does, however, and we will use it to demonstrate both Help menus.

First, select **Show Balloons**. Now, move the mouse over the names of the different Finder menus, and a balloon will appear that provides more information about that menu. You can also pull down a menu and balloons will appear next to the items. If you do not have a window currently open, either open a disk icon or one of the Apple menu items. Try pointing at the different parts of a window to see the help. You can turn off the balloons by selecting **Hide Balloons** under the Help menu.

Second, select **Finder Shortcuts**. This window provides a series of shortcuts for the Finder. Experiment with this, and when you are done close the window using the Close box.

Many Macintosh applications provide at least some on-line help. The units that follow will point out where to go for help when using each application. However, looking under the Help menu is usually the first place to check!
Unit 2: Using Simple Text

Simple Text is a program that allows you to create simple documents on the Macintosh. It also is used by many applications for displaying the documentation that accompanies the application. In addition to text, Simple Text can also be used to display some types of images, sounds, and video clips.

For use later this week, you will need a method of creating your own documents. Simple Text will work fine for this purpose. You will be able to edit existing documents, and create your own documents.

Starting Simple Text:

Simple Text can be started by selecting it from your “Capers” folder and choosing Open from the File menu. When using this method, Simple Text will open an empty window with the name Untitled. This can be used to create a new document. If you wish to edit an existing document, for example another Mosaic document, or continue to work on a document you started on before, you should first close the Untitled window. You can then use Open from the File menu to select the file to edit. (See the section Opening Files below if you are not familiar with opening files within Mac applications.)

The second method of starting Simple Text assumes you already have a file you want to work on. You can select the file by clicking on it, then selecting Open from the File menu. This will start Simple Text and will open the file automatically, rather than opening an Untitled window. There is a file named “Turkey” in your Capers folder that can be used with Simple Text. Try opening it.

Getting Help:

Simple Text supports Balloon help.

Basic Text Editing:

It will help when reading through this part, if you try typing some text along with the explanations. You can also open the Turkey file and make changes to it.

The basic idea behind creating documents with Simple Text is just to type in the Untitled window that appears when you first start Simple Text. You can type anything that you wish. When you reach the right side of a line, just keep
typing. Simple Text will automatically go to the next line, and will do so in between words, rather than in the middle of a word. This is known as wrap-around. When you reach a place where you wish to start a new paragraph, use the return key. You can use the return key more than once if you want extra space between the paragraphs.

There are several ways to correct mistakes in Simple Text (and in any editor or word processor on the Mac). The simplest way is to use the delete key located on the upper right of the keyboard. Each press of this key will move back one character, erasing that character. Once you have erased the incorrect text, you can resume typing.

But, what if the mistake is not discovered right away? To correct the mistake, you have to move the insertion point back to where the error is located. The insertion point is the blinking vertical line that appears in the window. It starts out in the upper left corner of an Untitled window and will move along with the typing. There are two ways to put the insertion point at a different point in a document. You can use the mouse — just point the mouse where you want the insertion point to be, and click. The second method is to use the four arrow keys located in the lower right corner of the keyboard. Each press of an arrow key will move the insertion point one character or one line in that direction.

Once your document becomes longer than will fit on the screen, the scroll bar on the right edge will become active allowing you to scroll up and down through the document. If you change the size of the window, by using the grow box in the lower right corner, you will notice the wrap-around effect on the text changes to conform to the new size of the window. Try a narrow window, for example.

Cut, Copy, and Paste:

The Edit menu in Simple Text allows you to move sections of text within a document, or from one document to another. To see how this works, select some text by dragging on the text. The selected text will be highlighted. To unselect the text, simply click the mouse anywhere in the window. Once you have selected some text, you can use the Edit menu. Let’s start with the Copy item. When you select this item, not much happens at first. However, Simple Text will “remember” the text you selected. It does this by storing the text in what the Mac calls the clipboard, a device for remembering the last item copied by any application. (You can select Show Clipboard from the Edit menu to see the text you put there!) To use the copied text, you will first need to click the mouse at a different point in the document, i.e., put the insertion
point in a new spot. Now, choose **Paste** from the **Edit** menu. The text you copied to the clipboard will appear at the insertion point. You can repeat this operation as many times as you wish, pasting the text into as many different places in the document as you wish.

**Cut** is almost the same as **Copy**, the difference being the action taken at the beginning. When you select some text and choose **Cut**, the text will disappear from the document (!) and go to the Clipboard. As with **Copy**, you can use **Paste** to put the text into another position in the document.

The final point to be made here is that you can transfer sections of text from one document to another. To see what this means, try the following: Select a section of text in your document, or the Turkey document.

1. Choose **Copy** from the **Edit** menu.
2. Choose **New** from the **File** menu. This will open a new Untitled window.
3. Choose **Paste** from the **Edit** menu.

The text you copied from the original document should now be in the new window.

**Fancy Text:**

Basically, this section will outline the purpose of the **Font**, **Size**, and **Style** menus. Once you have played with them a little, it is easy to figure out what all of the items do.

First, select a portion of text. Any size selection will do: one word, several lines, or a whole paragraph. The **Font** menu allows you to select a different font. Each font is a collection of all the characters the Mac can print, all done in the same style and size. A number of different fonts are available, and can be chosen from the **Font** menu. The size of the characters can be changed by selecting one of the point sizes from the **Size** menu. A point is a unit of about 1/72 inch used to measure the size of type; larger point sizes mean larger type. For comparison, this document uses the Times font in 14 point size.

The **Style** menu is mostly self-explanatory, since it shows you a sample of each style in the menu. Try selecting different parts of the text and changing the style. You can use combinations of some of the styles. For example, you can use **bold**, **underline**, and **outline** all at the same time!

**Saving Files:**

When saving a file for the first time, or saving a file under a different name than was used the last time, choose the **Save As...** item from the **File** menu.
The following save dialog box appears:

Enter the name of the file in the rectangle below the phrase Save this document as. In the example above, the program has already filled in the name “untitled 1”. You can type any characters you like except the colon (:). To enter a different name, point the cursor inside this box, click on the mouse button, and type another name. You use the delete key to erase characters you do not want and use the left and right arrow keys to move back and forth through the characters of the name.

Select the folder to save the file in. To save the file in a folder other than the current folder (displayed in the pop-up menu; in the above example, the Utilities item), you will need to perform one or more of the following steps:

1. To save in a folder in the scroll window, click on the folder. Then click the Open button to look inside the folder.
2. To save into a new folder under the current folder, click on the New folder button and enter a name for this new folder.
3. To save to a different disk, click on the Desktop button and select a disk.

Once you have entered the name of the file and selected the folder to place the file in, you are ready to click the Save button. If you need to save a file to a floppy disk and have not done this before, ask one of the TA’s for help.

Once you have saved a file, you do not have to always go through the save dialog box to save it again. You can choose Save from the File menu. This will
save the file using the same name and location as the last time. The new version of the file will replace the old one.

All Mac applications use a similar method for saving files, so the information presented here should help you with other applications.

Opening Files:

Select **Open...** item in the **File** menu. You will then get the open file dialog:

![Open File Dialog]

Select the file to open. Depending on where the file you want to open is located, you will need to perform one or more of the following steps:

1. To open a file in the current folder, click on the file name in the scroll window. Click on the **Open** button to open the file.
2. To open a file in another folder under the current folder, click on the folder name in the scroll window. Click on the **Open** button to open the folder.
3. To open a file on another disk, click on the **Desktop** button and select the disk.

All Mac applications use a similar method for opening files, so the information presented here should help you with other applications.
NCSA Mosaic, or usually just Mosaic for short, is an information browser that can query (or ask) other computers to acquire information. It is capable of obtaining information from a huge, and still growing, number of computers in the Internet. The Internet is a collection of computers that are connected electronically. The Mac that you are using, for example, is connected to the other Macs in the lab, to the printer, and to a collection of about 200 other computers in the Computer Science department. Through other communication channels, the department’s computers are connected to other computers around campus, across Arizona, the U.S., and foreign countries. The total number of computers on the Internet numbers in the millions, and is growing rapidly! Not all of them will provide information for Mosaic. For example, of the machines currently in the CS department, three have information that Mosaic can access. A number of additional machines on campus have Mosaic information available, and some supply information in different formats that Mosaic can read.

But, getting back to the local scene, before you can explore some of the possibilities on the Internet, you need to have a set of tools that can handle the different kinds of information available. So, we will start by working through some examples of the types of information that Mosaic can find. Then, when you know how to handle the information, you will be able to explore the Internet and hunt for information in a variety of formats, including text, pictures, sound, and movie clips.

Mosaic Controls:

Locate the Mosaic application on your Mac’s disk drive. It should be in a folder named “Capers”. Start the application named NCSA Mosaic. (NCSA is the National Center for Supercomputing Applications, the place where Mosaic was created.) It will take a minute or so for the application to start. When it is ready you will see a window entitled “Local Home Page”. A home page is a beginning point in exploring information on a particular computer. Some computers will provide many pages of information and the home page will contain references (called links) to the other pages. For your Mac, we have set up the “Local Home Page” with links to a number of images, video clips, and sounds. The upper part of the Mosaic window, showing the “Local Home Page”, is shown on the next page.
Local Home Page

Local Things to do

- gif Picture Horsehead nebula
- gif Picture Three Wolves
- gif Picture Large image
- QuickTime Movie Seals on the pier
- Mpeg Movie Nancy Kerrigan
- Sound file Eagle has landed
- Sound file What's Up Doc?

Capers Home Page
There are several controls along the top of the window, just below the title bar. Some of them won’t do anything right away, but all of them will be useful in the future.

The Mosaic World symbol acts as a status indicator. When Mosaic is working to find something, it will take on different shapes depending on the type of information it is finding. The other three items shown above allow you to move backwards and forwards through information you have already located. The third item will take you back to your Home Page. In using Mosaic, you may end up looking at a Mosaic document, not be sure how you got there, or where to go next. This can even happen when you are trying out the items suggested below and in the next several units. You can always return to the "Local Home Page” by simply clicking on the Go To Home Page button!

The Current location shows the name of the information page you are currently viewing, in this case the Home Page for your Mac. The pop-up menu won’t do anything just yet, since only one page, the Home Page, has been accessed so far. However, don’t forget about it as it will prove useful later on. The complete Internet name provides a detailed description of how the current page was located. In this case, the first word tells us that a file on the current machine was loaded, and the rest of the information tells exactly where the file was found on the disk, including the names of all the folders that had to be opened to locate the file. (That part may be different on your machine.)

Beginning Navigation:

Navigating in Mosaic refers to the process of finding your way through the information that Mosaic makes available to you. Mosaic provides a mechanism for displaying text and images within the Mosaic screen and for acquiring other forms of information (sound, pictures, video clips). Colored text indicates there is additional information that can be acquired, and clicking on this text will retrieve the information. Blue indicates information that you
have not seen before, and red is used for information you have seen before.

Mosaic information comes in several formats. In some cases the information will be displayed inside the window. In other cases, the information is in a different format and Mosaic will start another application to display the information. If Mosaic gets an image, for example, it will start an application called JPEGView and give the image to it. After viewing the image, you quit JPEGView and the Mac will go back to Mosaic and let you continue your explorations.

**Important Note:** You may unexpectedly end up in an application that is not familiar to you when using Mosaic. Each Macintosh application has a File menu, and there is always a Quit option in it. Just use that and you should return to Mosaic. You can also use the Application menu to select Mosaic.

To get a short introduction to this idea, there is an item in the “Local Home Page” that says “Capers Home Page”. It should be in blue near the bottom of the Mosaic window. Click on the blue words. There will now be a short pause. Mosaic is seeking information from a computer upstairs in the CS department and will bring the information to your Mac. This will take anywhere from 20 seconds to a minute or so. The delay is due to a number of factors:

- **Network delays:** The communication connections in the Internet are composed of some high-capacity connections and some low-capacity connections. If you happen to use a computer with a high-capacity connection, you will get a quick response. If not, then you will have to wait longer.

- **Server workload:** The server is the computer that is supplying the Mosaic information to you. It may be supplying information to others at the same time. This workload will slow down the flow of information.

- **Client capacity:** The client, in this case, is your Mac. A client is the computer that is requesting the information from the server. In some cases, the delay is caused by your Mac not being able to process the information quickly enough.

The server that provides the “Capers Home Page”, has a fairly high capacity connection, so the information will come as fast as your Mac can handle it. If many of the other Capers groups are accessing the same page, you will see some additional delay as the server computer is trying to answer all the questions at once! Still, the server is on campus, so the response time will
be better than you will see when trying to retrieve information from a remote server.

Click on the Back button to return to your “Local Home Page”. Then, click on the Forward button to return to the “Capers Home Page”. Notice you do not have to wait for the “Capers Home Page” to load. Mosaic has cached the information, that is, it has held the information locally on your Mac so it does not have to query the server for it again. Finally, the pop-up menu will now work and will display both of the pages you have seen. You can select a page here to go to as well.

Some Menu Options:

Take a moment to look through the different pull down menu options on the menu bar for Mosaic. In particular, notice the Navigate menu also will allow you to go Back, Forward, and Home. This is the same as the browse buttons on the top of the Mosaic window.

Next, look under the Options menu. We will do a quick experiment here. If you are not on the “Local Home Page”, return there first. Then, under Options, select Flush Cache. Then, click on the Forward button. Mosaic remembers where the information came from, so the forward command will work; however, since the cache has been flushed, it will have to reload the information from the server computer.

Now, do the same sequence again, but let’s add another step. Return to the “Local Home Page”, select Flush Cache, and select Auto-load Images. When you do this last step, the check-mark that was present in the pull-down menu next to the item will disappear. Now, use Forward to load the “Capers Home Page”. Notice anything different? The page loads faster, but the images are not present! This technique can be useful when you suspect it may take a long time to load all of the information you have asked for. Without the automatic loading of the images, only the text is loaded. To see the images, you will have to ask for each one individually. To do this, point the mouse at one of the symbols. This represents an image that Mosaic did not load, but knows how to ask for. When you click on it, Mosaic will request the image and will replace the symbol with the image.

Helper Applications:

As mentioned before, Mosaic will invoke helper applications when it receives information that it cannot process on its own. The next four units will each
describe one helper application:

Unit 4: JPEGView, for viewing images
Unit 5: Movie Player, for playing video clips in the QuickTime format
Unit 6: Sparkle, for playing video clips in the mpeg format
Unit 7: Sound Machine, for playing audio

To work through each unit, return to the “Local Home Page” in Mosaic, then go to the unit. Each unit will explain the steps to load the information and take you through the controls for the application.

Getting Help:

Balloon help is not supported by this version of Mosaic. There are some help items available, though, under the Help menu. The help files that are referenced under the Help menu are on a computer located at NCSA at University of Illinois at Urbana-Champaign. You can select one of the items, but may notice a fair delay before the file arrives. To make this process less costly, the same files are on a computer named ‘schooner’, located upstairs on the seventh floor. This is the same computer that supplied the “Capers Home Page” you were using earlier. To get the Help files from schooner, you will need to use the Hotlist menu. When you pull down this menu, you will find the window shown at the top of the next page. The four items from MacMosaic Documentation through FAQ, match the four Mosaic help items that are available under the Help menu. In case you are not familiar with some of the more arcane terms of computer science, FAQ is short for Frequently Asked Questions, and is a common abbreviation among computer folks. HTML and URL are explained in a later unit; though, you can also find them in the Glossary. The last two items point to Mosaic pages about the University of Arizona and the Department of Computer Science. You are welcome to try them out, if you wish. You can go to any of the pages by double-clicking on that entry. The buttons at the bottom of the window will be explained further in Unit 8: Net Surfing.

Keep in mind how to access the help information for Mosaic, as it will come in handy later on!

Cloning Windows:

Mosaic can support multiple windows open at the same time. This is usually controlled by you through the File menu; though, in some cases Mosaic will create extra windows automatically. They are described here since the ability to create multiple windows can be very helpful when using Help! It can get
tedious when you need to look in a Help file to find something out, and then have to find your way Back to the window where you needed the help.

An easier way is to put the Help information in a separate window. To do this, you first select either New Window or Clone Window from the File menu. New Window will create a new Mosaic window with the “Local Home Page” loaded. Clone Window will make a complete copy of the currently active Mosaic window. The cloned window will have the same history as the original window; you can move Back and Forward through the same sequence of Mosaic pages.

When using Help, it works well to make a new or cloned window first, then select the particular Help page you need. This will allow you to have the Help page open to the section you want to read, and be able to switch back to the old window to try out new ideas you learn from the Help page.
Unit 4: JPEGView

JPEGView is a program for looking at pictures on the Macintosh. It is able to view pictures in a wide variety of formats. In particular, it is able to view pictures that are in GIF and JPEG formats. Both of these are photo compression techniques that save space on the hard drive of the computer, or that can save time in transferring photos as happens in Mosaic. More on the compression techniques appears below.

To get started with this unit, you will need to start JPEGView with a picture to view. The easiest way to do this is to select a picture from the Mosaic home page for your machine. Clicking on gif picture Horsehead Nebula will load an astronomical picture of the Horsehead nebula and will start JPEGView with this picture displayed.

Pictures which are too large to be on the screen at once are scaled to fit the screen. In scaling, both the width and the height are reduced proportionally. Thus, if the image is too tall to fit and is reduced by one-fourth in order match the height of the screen, the width is also reduced by one-fourth.

Getting Help:

You can select Balloon Help or JPEGView Help under the Help menu for more information. The first unit explains how Help menus work.

Experimenting with Sizes:

JPEGView supports the ability to expand or shrink the picture. The controls for re-sizing are located under the View menu. Try using Normal Size, Double Size, and Halve Size to change the picture size.

The Maximum Size item allows the image to expand to the size of the screen, giving you a blow-up of the image. While the picture is larger, it is not as distinct, or sharp, an image. Try switching between the Normal Size and Maximum Size choices a few times to see this difference. When the image is first created, a certain number of dots, or pixels, are used in forming the image. When shown at normal size, the image uses exactly the number of pixels on the screen as were specified in the original image. When the image is expanded to a larger size, JPEGView has to figure out what colors to use for the extra pixels that are now part of the picture. It does this by a process of interpolation, finding a color for a new pixel that is roughly in between the colors of the pixels on either side. The more the image is expanded, the greater
the number of pixels that have to be interpolated to create the new image. For small images that are expanded a large amount, the picture may be hard to see. Try this when you next load a small image. The **Show Statistics** item in the **Window** menu will tell you, among other things, the number of pixels in the image. How many pixels are in the Horsehead Nebula picture?

The mouse can also be used to change the size of an image. Move the mouse to the lower right corner of an image, where the grow box normally would appear. The cursor will change into a grow box shape: 

Now, you can change the window size as described above. By default, the window will be re-drawn with the width and the height in the same ratio, just as was the case when using the menu options to change the size. To get an interesting effect, try changing the size of the window while holding down the shift key. In this situation, the program is not scaling the image, but allowing you to change the width and height in a non-proportional manner. So stretch it, or shrink it, or do both at the same time! Remember, you can always return to the original image size by choosing **Normal Size**.

The **Full Screen** option was saved until now to explain since it makes more sense after you have had a chance to use the other size features. When you select **Full Screen**, the menu bar will disappear. Experiment with this option. (Hint: you can get the menubar back by clicking on the mouse.)

**Resize To Screen** has different effects depending on whether the image’s normal size is less than, or greater than, the screen size. When less than the screen size, such as in the Horsehead nebula image, the image will revert to its normal size. In this case, **Normal Size** and **Resize To Screen** have the same effect. The effect is different for a large image, try it when you load a large image.

As a final step in using the various size options, load an image that is too large for the screen. One example that you can use is to return to Mosaic (which can be done with the Application menu ( ) in the menu bar’s extreme right). In Mosaic, select the item:

```
 gif picture Three Wolves
```

This will load an image that is too large to fit on the standard size screen. Once the image has been loaded and JPEGView is ready to display it, you will see
a dialog box that asks:

The image “wolves-3.gif” is too large to fit in an onscreen window without scaling. Do you want to open it in a full screen window?

Normal  Full

JPEGView is asking whether you want the menu bar and window title bar shown when the image is displayed.

Selecting, Cropping, and a Slide Show:

JPEGView provides some limited ability to crop images, that is, it provides a way of selecting a portion of an image and zooming in on that portion. To experiment with these features, you will need an image open in JPEGView. For example, either the Horsehead nebula or the three wolves picture will work fine.

With the image open, you will notice that the mouse changes to a crosshair shape when it is inside the image. If you drag the mouse, you will see the crosshair stretches a dotted rectangle across the screen. This is a method of selecting a particular section of an image to view. When you release the mouse button, the rectangle stays on the screen. When the mouse is outside the rectangle but still inside the image, it keeps its crosshair shape. Pressing the mouse button in this situation will cause the dotted rectangle to disappear, and a new rectangle can be drawn. Moving the mouse inside the dotted rectangle, however, changes it to a hand shape. With the hand, you can move the rectangle to a different part of the image by holding down the mouse button and moving the mouse.

Once you are satisfied with the position and size of the rectangle, you are ready to crop the image. Under the Edit menu, select the item Crop & Zoom. A new window will open and will show only the part of the image you selected. You can still perform all the above operations on this new image. For images that are too large to fit at 100% of size on the screen, cropping is a way of zooming in on a region of interest to you and seeing it at full size.

One interesting feature of cropped images in JPEGView is that the entire image is still present in the file. You can select Uncrop from the Edit menu, and the original image will return.
The Select Screen Area can be used on an image that is too large to fit at full size on the screen, such as the three wolves image. With such an image open, Select Screen Area will display a dotted rectangle on the image. This represents the largest section of the image that can be displayed without scaling on the screen. The mouse can be used to move the dotted rectangle to a different section of the image. Then, Crop & Zoom can be used to show the selected portion of the image at full size.

JPEGView can be used to show a sequence of images in a slide show format. This can be done with images from disk, or images already loaded by the program. As an introduction to this, load one image, then create several additional versions of the image by cropping it. You can, for example, make a series of images that zooms in closer and closer on a particular part of the original image. Once you have the several images created, and have made each the size you would like it, select Slide Show Options... from the File menu. Set the options on it as they appear below:

The Images in Memory option is a pop-up menu, which allows you to choose between showing images in memory or on disk. The other pop-up menu allows you to choose to an automatic or user-controlled slide show. Click the Begin button when you are ready to view the slides.

Other Things to Try:

There are things that can be done with JPEGView that have not been covered here. To give you a pointer or two on things to try, here are some hints:

1. JPEGView can save images, but cannot save all images. The differences are explained in the JPEGView Help... Knowing which
types of images can be saved may be useful if you download an image in Mosaic and would like to save it for future use. For images that cannot be saved in JPEGView, there is a way to save an image when at the time it is downloaded in Mosaic.

2. When you have collected several images, you can try a slide show using the images stored on disk. This will allow you to experiment with more of the options than can be done with images stored in memory.
**Unit 5: Movie Player**

Movie Player is a program for viewing QuickTime movies. QuickTime movies are video clips, often including sound tracks, that can be played on the Macintosh. The program gives you the opportunity to halt the movie, replay all or a part of the movie, and control the size of the image and the volume of the sound.

To get started with this unit, you will need to start Movie Player with a movie to view. The easiest way to do this is to select a movie from the Mosaic home page for your machine. Clicking on **QuickTime Movie** Seals on the pier will load a short movie clip about a pair of seals playing king-of-the-hill on a pier in San Francisco harbor.

**Getting Help:**

You can select **Balloon Help** or **MoviePlayer Help** under the Help menu for more information. Help menus are described in the first unit (Getting Help:).

**Playing the Movie, Basic Controls:**

The basic controls for MoviePlayer are located at the bottom of the window.

![Basic Controls Diagram](image)

This figure was taken from the **MoviePlayer Help** window.

To start the movie, click the Play/Pause button (clicking it again during the movie will halt the movie on the current frame). The Play Bar shows the relative position of the current frame of the movie.

While the movie is halted, you can move the Thumb with the mouse. You can also just click at some point on the Play Bar, and the Thumb will jump there and show the frame at that position. The step forward and step backward
buttons allow you to move forward or backwards through the movie one frame at a time. Click on either button to see this. If the movie has a sound track, it will not play when using the step buttons.

The sound button on the left can be used to control the sound volume. To adjust the volume, point at the Sound button and hold the mouse button down. A sliding scale will appear just to the left of the Sound button. By moving the mouse up and down, you can change the volume. Notice that the Sound button itself changes to indicate the relative volume setting.

**Re-sizing and Some Other Effects:**

Playing a movie is interesting, but there are some other things you can do with the movie. For starters, you can change the size of the movie. This can be done in two ways, either by using the grow box, , in the lower right corner, or by selecting options from the Movie menu. If you make the movie window larger, you will see two effects. The first is that the images will appear blurry. This is the same effect that was present in JPEGView when an image was made larger than the number of pixels used in creating it. This leads to the second effect, that the movie may play slower. How much slower is a function of how much larger you have made the window than the original size.

If you make the window smaller, however, the movie does not play faster. Why not? The movie file contains information telling the computer how fast to play the movie; that is, how many frames of the movie to show each second. The program will not play the movie faster than this speed, even though the smaller size would allow it to.

**Selecting and Editing:**

Simple Player will allow you to select a portion of a movie. There are several ways to do this; the MoviePlayer Help window outlines all of them, so just one of them is described here. You can check out the other methods on your own.

Position the Thumb somewhere in the Play Bar. Now, hold down the shift key, and then click at another spot in the Play Bar, either to the left or the right of the Thumb's position. The section of the Play Bar between the Thumb and where you clicked will turn dark. Now, under the Edit menu, choose Copy. Next, go to the File menu and choose New. You will get a window that has a title bar and the controls, but no image in between, i.e.
Go back to the Edit menu, and choose Paste. Your selection will now appear in the new window, and you can use the controls to play it.

You can save this selection as a QuickTime movie in a separate file. Use the Save As... item in the File menu to do this. If you are not sure how the Save dialog box works, check out Saving Files: in Unit 2: Using Simple Text. One selection that is different here from the normal Save dialog box is the following choice:

- **Save normally (allowing dependencies)**
  Estimated file size: 3K
- **Make movie self-contained**
  Estimated file size: 659K

Which of these you choose is up to you. If you are saving a movie to use in a Mosaic page, it is usually best to choose the second option. Making a self-contained movie allows the movie to be played even if the original movie that it came from is not present on the machine. (MoviePlayer Help explains the differences between the two methods in some additional detail.)

**Other Things to Try:**

1. There are a number of keyboard shortcuts that can be used with MoviePlayer. Keyboard shortcuts are a method of manipulating the controls without using the mouse. Other commands use the keyboard in combination with the mouse to allow you more options on what can be done with a movie. The various shortcuts and extensions are described by MoviePlayer Help. Try them out and see which ones will be useful to you.

2. When selecting a portion of the movie to copy to a new file, there are a number of methods that can be used. In particular, some of these methods make it easier to pick a specific starting or ending frame for the selection, giving you more precise control over the exact frames you wish to include in the selection. They are described by MoviePlayer Help. Try some of them out. You can also select individual frames from a movie and paste them into another movie, or another place in the same movie. Thus, a movie can be made of clips from several movies, or even the same clip repeated several places in the movie.
Unit 6: Sparkle

Sparkle is program for viewing mpeg movies, which are video clips that sometimes contain sound. They are similar in principle to QuickTime video clips. The main differences lie in the compression techniques used for the two standards. QuickTime movies play much faster on the Macintosh since the Mac has software designed to optimize the playing of QuickTime. As with Simple Player, Sparkle provides controls for playing all or part of a movie and moving forward and backward through the file.

To get started with this unit, you will need to start Sparkle with a movie to view. The easiest way to do this is to select a movie from the Mosaic home page for your machine. Clicking on Mpeg Movie Nancy Kerrigan will load a short movie clip of Nancy skating.

Getting Help:

Sparkle does not support on-line help. Thus, you won’t be able to ask the program for help while running it.

Playing the Movie, Basic Controls:

The basic controls for Sparkle are located at the bottom of the window:

They are very similar to those used by MoviePlayer; this was a deliberate choice by Sparkle’s author. The Play/Pause, Step Forward, and Step Backward buttons are very similar in their use to those present in Simple Player. Notice there is no Volume button. The Sparkle program does not support sound in mpeg movies.

Try playing the Nancy Kerrigan movie. One thing you will notice right away is the slow speed of the movie. This is due to the greater amount of work the program is doing to convert the information in the mpeg file to create the individual frames of the movie. Still, you can play the movie forwards and backwards, as well as advance the movie one frame at a time by using the Step Forward and Step Backward arrows. You can also move the Thumb on the Play Bar by clicking at a new location.
Creating a Faster Movie:

Okay, so watching the movie at this slow pace is very boring! Take heart, there is a solution. Sparkle has the ability to create a QuickTime movie from an mpeg movie. The way to do this is to choose the **Save As...** item in the **File** menu. (If you are not familiar with saving Macintosh files, see **Saving Files:** in **Unit 2: Using Simple Text**) You will get the standard save dialog box with an additional pop-up menu near the bottom of the dialog box. When you select this, you will see:

![Save As dialog box]

You can save movies in the mpeg or QuickTime formats. Select the **QT Movie** option. This will bring up another dialog box before the saving process begins:

![Compression Settings dialog box]

For now, go ahead and click the **OK** button. Later, you might want to come back and try some of the other options to see what effect they have on the resulting QuickTime movie. It will take a while to perform the conversion and save the movie. For the Nancy Kerrigan movie, it takes about a minute and a
half to save the movie. As the movie is converted and saved, it will display each frame in the window. This is a way of showing you the progress Sparkle is making in saving the file.

Once the save is finished, you can use **Open...** in the **File** menu to select the QuickTime file you just saved. (If you are not familiar with opening Macintosh files, see the section on **Opening Files: in Unit 2: Using Simple Text**) Try playing the movie now. You will also be able to play the QuickTime movie using Simple Player.

One thing to notice is that a Volume button appeared when you opened the QuickTime movie. Unfortunately, the Nancy Kerrigan movie clip does not have sound with it, so the Volume button has no effect. Sparkle can, however, open other QuickTime movies. For example, if you saved all or a part of the Seals movie when you were doing the Simple Player unit, you can open it in Sparkle and play the movie with sound.

**Other Things to Try:**

1. What happens when different options are selected during a conversion to QuickTime format? Under the pop-up menu initially labeled **Video** are a number of other options to use for the compression technique. Does selecting a different one make the resulting QuickTime movie play slower or faster? Does one option allow a faster or slower conversion to QuickTime?
Unit 7: Sound Machine

To get started with this unit, you will need to start Sound Machine with a sound to play. The easiest way to do this is to select a sound from the Mosaic home page for your Mac. Clicking on

Sound file Eagle has landed

will load a short sound file and start playing it.

Getting Help:

Sound Machine has all of its on-line help in the form of balloons. Simply select Show Balloons from the Help menu.

Playing the Sound, Basic Controls:

The basic control panel for Sound Machine will appear when a sound is being played:

You may find that you have to listen closely to hear the sound; the built in speaker on the Macintosh does not play very loud.

Most of the controls are fairly obvious (and Balloon help can provide additional explanation for you). The interpolation method button toggles between different methods of interpreting the sound. Many, but not all sounds will play correctly on the default setting. The Eagle sound will play correctly...
on the default, but you try the other methods to see how sounds do not always come out right! The sampling rates button is similar in that not all sounds will play correctly at the default setting. See how the sampling rates affect the sound! The general rule for sounds that do not come out right the first time is: If the sound is too fast or too slow, use the sampling rates button; if the sound has a lot of static in it, use the interpolation button.

The forward and back buttons can be used to vary the speed at which the sound plays. Click once on the back button to hear the sound at normal speed, but playing backwards. Click it again, and the sound plays faster. The forward button works in the same manner. You can click the play button to return to playing the sound at the normal, forward pace.

Queues of Sounds:

Sound Machine can have more than one sound file open at a time. This will happen, for example, when you select a sound in Mosaic, then select another sound. You can try this by selecting Mosaic (from the Application menu) and clicking on another sound (such as the “What’s Up Doc?” sound).

The pop-up menu on the Sound Machine controls shows the sound currently playing. You can use it to select the sound to play next. Also, the buttons  and  will select the previous and next sounds respectively. Clicking on one of them will interrupt the current sound, and jump to the next sound.

When the sequence of sounds has completed, or when you click on the Close box for the control panel, the panel will disappear. The Control menu, however, becomes active in this case. You can select Play from it to bring the control panel back and start playing the sounds. The Select from Queue item can be used to determine which sound will start playing when you choose Play. Finally, the Remove from Queue item can be used to delete sounds from the sequence.

Other Things to Try:

1. There are keyboard equivalents for all of the control panel buttons. That is, there are keys on the keyboard that you can press instead of using the mouse to click on the buttons. For example, the up and down arrow keys can be used to control the volume. Can you figure out what the others are?
Unit 8: Net Surfing

Mosaic is a browser for exploring the Internet. The goal of this unit is to do just that. Along the way, some things will be suggested for you to try, but you are largely on your own. Mosaic provides some features to help you remember where you have been, and they will be described below. You may also, however, find it helpful to write things down.

Beginning Net Surfing:

Net surfing is a term that has been invented to describe the process of visiting Internet sites. The basic idea is to enter the URL (explained below) for a site you want to visit. Mosaic will then query the Mosaic server for that site and download the page you requested to your Mac. You will find that many of the pages you obtain will have links to other pages. The “Capers Home Page”, for example, contains links to other Mosaic documents as well as images, videos, etc. In some cases the links are to local documents that reside on the same computer that you listed when you opened the link. In other cases, the link will take you to a different computer.

URL:

Mosaic uses a Uniform Resource Locator, or URL, to determine where to query when you click on a link, which is a blue or red item in the Mosaic window. The URL tells Mosaic:

• How to transfer the information it finds
• What computer to ask for the information
• Where to look for the information on that computer

In Mosaic, under the File menu, select the item Open URL... You will get the following Load URL dialog box:

The white rectangle in the middle will be empty when this first appears, but you should go ahead and type what appears there. In case the text does not show up clearly on the printout, type:

http://seds.lpl.arizona.edu/seds/seds.html
This will access a Mosaic server on the U of A campus that is run by the Students for the Exploration and Development of Space (SEDS). When the page loads, you will find that it contains a list of other Mosaic pages (the parts of the text that appear in blue) that you can access just by clicking on them. Before you do, though, a bit more explanation is in order. First, the URL that you entered above, consists of the following three parts, and all the URL’s used with Mosaic will have the same parts:

http:

How Mosaic will transfer the information. Usually this will be ‘http’ (HyperText Transfer Protocol), but you may also see URL’s that use ‘file:’, ‘ftp:’, ‘gopher:’, or ‘wais:’. Each of these is a different transfer mechanism. Mosaic can handle all of them, but the way the window appears for each will be different.

seds.lpl.arizona.edu

Which computer Mosaic will ask for the information. In this case, a computer named seds, located at the Lunar and Planetary Lab (lpl) at the University of Arizona (arizona.edu). Some computer addresses are easy to figure out; others are more obscure. If you get an address that looks interesting, write it down and ask one of us about it.

seds/seds.html

Where to find the information Mosaic is to obtain on the seds.lpl computer. In this case, the information is located in a folder named ‘seds’ in a file named ‘seds.html’. The suffix, .html, is important to Mosaic, since it describes the type of information that Mosaic will receive. ‘html’ is HyperText Markup Language, and is the subject of Unit 10: Writing Mosaic Documents.

Mosaic will display the current URL for the page you are looking at near the top of the window. You can, if you wish, hide this display using the Hide URLs item in the Options menu. The Options menu also has an item named Hide Status Messages. This refers to the area in the Mosaic window just below the current URL section. Different messages will appear here when Mosaic is attempting to download information for you, including some error messages. One last thing to point out about the status messages: when you point the mouse at a link, such as one of the blue items on the SEDS page, the status area will show the URL for the link. If you click on the link, Mosaic will use this URL to obtain the information you are requesting.

Go Adventuring!:

There are lots of places to explore, and the idea here is to do just that. We will suggest some places to check out below, but do not feel you have to explore
each of them in turn. You are especially encouraged to discover sites on your own! The one thing we ask is that you write down a few of the good places you find, to share with others in the group. Also, write down a few sites that you did not like, either because there was nothing interesting there, or because you had to wait too long for the information. This way, others won’t have to take the time to discover there is nothing interesting at those sites.

The most common way to find sites is to start with a site and begin exploring links from that site. The SEDS page you loaded earlier, for example, contains links to a number of other pages, some located on the U. of A. campus, and some at other universities.

The last point to mention before you begin your journey, is that Mosaic does provide some additional tools to help you in remembering where you have been, and ways to save interesting items you discover along the way. They are described in more detail later (in the sections named Remembering Where You’ve Been and Capturing Files). You do not need to read those sections now, but may want to check them out later on. Their usefulness will actually be more obvious after you have done some exploring.

Places to Explore:

NCSA maintains a list of interesting sites that you can explore. Rather than entering the URL yourself, you can select one of four pages to explore from choices under the Navigate menu:

- Network Starting Points
- Internet Resources Meta-Index
- NCSA Demo Page
- NCSA What’s New Page

Each of these has links to other pages, some at NCSA, some at various sites around the country and the world. A number of the sites listed below were found through links on these NCSA pages.

- NASA and Space
  
  http://spacelink.msfc.nasa.gov/
  
  The NASA SpaceLink is an electronic information system available for use by the educational community. It offers a wide range of materials (computer text files, graphics, and software) related to the space program.

  http://www.nasa.gov/

  This is the main NASA Home Page. It contains links to each of the NASA Research Centers around the country. Also, it has links to some
NASA information, check out the NASA Hot Topics item!
http://zebu.uoregon.edu/galaxy.html
Interesting images and video clips of stars, galaxies, etc. Includes images from the Shoemaker-Levy comet collisions with Jupiter.

- Los Alamos National Labs
  http://www.lanl.gov/welcome.html
  http://www.acl.lanl.gov/Home.html
  There are some interesting videos and images accessible through these pages.

- Russia
  http://www.kiae.su/www/wtr/
  A foreign site to check out, in particular, try the virtual exhibitions. There is information about Moscow, including some images from various places around the heart of the city. Why is there a piece missing from the large bell?

- Japan
  http://www.ntt.jp/japan/
  A foreign site in the other direction. There is information and images about places in Japan. You can practice Japanese phrases, and listen to the Japanese National Anthem. There are satellite weather images for Japan. Why is the latest image for “tomorrow”? There are two Sumo wrestling videos accessible through links from this page (1 QuickTime and 1 mpeg).

- Exploratorium
  http://www.exploratorium.edu/
  A science museum in San Francisco. Check out the “Digital Library”.

- GNN
  http://nearnet.gnn.com/gnn/GNNhome.html
  GNN stands for Global Network Navigation. They have a lot of interesting options available off their home page. Since this is a popular site, you may have to be patient to wait for the information to load when accessing it.
• EXPO Ticket Office
  http://sunsite.unc.edu/expo/ticket_office.html
  A collection of museum exhibits that you can visit electronically. The main location is at the University of North Carolina, but some of the museums are located in other places (where?). For example, you can learn about Columbus, or find out about dinosaurs.

• MTV
  http://mtv.com/
  The MTV site. Still under construction, but there are some Oddities pages with movies and some sounds.

• Adam Curry’s Web site
  http://metaverse.com/vibe/
  Run by Adam Curry, the former MTV VJ. There are some images and audio selections available here that you might find interesting. Be patient when downloading some of the larger items.

• Science Images and Videos
  http://www.ncsa.uiuc.edu/SDG/DigitalGallery/DG_science_theater.html
  A variety of images and videos from different scientific areas. The areas include Earth Sciences, Medical Imaging, Fluid Dynamics, and more. For example, there is a good mpeg movie of the splash from a ball dropping into a liquid. Can you find it?

• Songs
  http://ftp.luth.se/pub/sounds/songs/
  This site has a long list of songs by a variety of artists. Is the quality of the sounds the same as those available at Adam Curry’s site? Do they download slower or faster?
  http://www.best.com/~casa/web_directory.html
  This site contains links to sounds and pictures of a cappella groups.
  http://www.uwp.edu/
  Contains a link to a site with words to lots of songs. May be overloaded, so you might try:
http://www.wit.com/mirrors/music

- Coke Machines
  
  http://www.cs.cmu.edu:8001/afs/cs.cmu.edu/user/bsy/www/coke.html

  This one is a little different. It contains links to coke machines that are on the Internet. You can find out which machines have cold cokes available.

Searchable Mosaic Sites:

Some Mosaic sites support “keyword searching”. This is a feature that allows you to enter one or more words, and the site will respond with information related to those words. There are several sites which allow searches of other mosaic sites:

  http://webcrawler.cs.washington.edu/WebCrawler
  http://www.winc.com/W3Catalog.html

Try entering the following URL:


When the page has finished loading, you will have the chance to enter a search word, or selection of words. You can type into the box next to the Query entry:

![Query: song and lyrics](image)

When you have made the entry, click on the Submit button. A request has now been sent to the remote machine to look for homepages that match your request. You’ll get back a list of sites, which you can click on, and a brief description of what each site contains. For example, try some of the following:

- movies
- sounds
- a favorite sport (soccer, basketball, baseball, etc.)
- song lyrics
songs
music

You may find other sites on the Internet that have searchable pages!

**Other Sites to Try:**

MIT

http://www.mit.edu:8001/

Baseball’s Hall of Fame

http://www.enews.com/bas_hall_fame/overview.html

Dilbert page

http://www.unitedmedia.com/comics/dilbert/

Late Night

http://bingen.cs.csbsju.edu/letterman.html

Classic Literature

http://www.ai.mit.edu/people/torrance/literature.html

FBI

http://naic.nasa.gov/fbi/FBI_homepage.html

Peter Gabriel

http://www.cosy.sbg.ac.at/rec/Gabriel/
http://www.cs.clemson.edu/~junderw/pg.html

Books On-line

http://www.cs.cmu.edu:8001/Web/books.html

Doctor Fun

http://sunsite.unc.edu/Dave/drfun.html

Weather report for arizona

  gopher://wx.atmos.uiuc.edu/11/States/Arizona

Arizona Daily Wildcat

http://www.arizona.edu/pubs/wildcat/wildcat.html

Fractal Imaging Archive (computer generated movies)

http://www.cnam.fr/fractals/anim.html
Dinosaurs
http://www.hcc.hawaii.edu/dinos/dinos.1.html

Sports — hockey, basketball, football, and a variety of international sports
http://www.netgen.com/sis/sports.html
http://www2.nando.net/sports/moresports/moresports.html

Biology (the study of life) interests
http://golgi.harvard.edu/biopages.html

A Large Site for Pictures, Movies, Music, and Lyrics
file://ftp.sunet.se/pub/

For more general helpful searching areas try:
http://viswiz.gmd.de/MultimediaInfo
http://sunsite.unc.edu/heliocentric.html
(The Gateway to Cyberspace)

The White House
http://www.whitehouse.gov/

The U.S. House of Representatives, legislative information
http://thomas.loc.gov/

The Grand Canyon
http://kbt.com/gc/

Meteorology
http://meawx1.nrrc.ncsu.edu/

MayaQuest Learning Adventure - Adventures of young people travelling through Central America
http://mayaquest.mecc.com/

Kid’s Space - A home page for kids by kids
http://www.interport.net/kids_space/index.html

Remembering Where You’ve Been:

You will quickly discover that you lose track of where you have been in your surfing. You can, of course, use the Back and Forward buttons to trace your path. That is helpful, but will not be of any help, for example, when you come
in the next day and cannot remember how to find that interesting page! Mosaic provides a **hotlist** tool for just this reason.

A hotlist in Mosaic is a list of sites. The list contains the title of the site; this is what appears in the title bar of the Mosaic window when you are at the site. The hotlist also contains the URL Mosaic needs to contact the site again. You can access the hotlist through the Hotlist pull down menu, selecting the item Hotlist (I know, a bit repetitious!). You’ll then get the window shown below. You’ll find the Hotlist contains several entries already. These were explained under **Getting Help:** in **Unit 3: Mosaic Introduction**. You can select one of the sites listed in the Hotlist by double-clicking the name.

![Hotlist Items window](image)

**List of active Hotlists**

**URL of highlighted entry**

**Create a new, empty Hotlist**

**Open another existing Hotlist**

**Add entry to Hotlist**

**Change/Correct an entry**

**Delete highlighted entry from current Hotlist**
Editing the Hotlist:

To add a site to your hotlist, you have two choices. If the Hotlist window is open, you can use the button [Add Doc]. This will bring up a dialog box that will allow you to type in a URL and a title. However, since all we’re doing at this point is adding the current document, you can simply select the [Add Current] button in the dialog box. The second choice for adding the current document to the Hotlist is to select the [Add This Document] item from the [Navigate] pulldown menu. When you next bring up the Hotlist window, you’ll see the new item(s) that you’ve added at the bottom of the list.

To edit an item in the hotlist, select the item you want to edit in the scroll window, and click on the [Edit Doc] button. This will bring up the [Hotlist Item Dialog] box that allows you to change the title or the URL for the item.

To delete an item in the hotlist, select the item you want to delete in the scroll window, and click on the [Del Doc] button.

Hotlist Full?:

You may run into the problem of the hotlist filling up. If this happens, you simply need to create another hotlist. To do this, select the [New HL] button. This will create a new [Untitled Hotlist]. When you add a new item to the hotlist, a dialog box will be displayed allowing you to enter the name of the hotlist file.

When you start Mosaic up the next day, it will load the original Hotlist. You can change to the new one by selecting the [Open HL] button. This will bring up an open dialog which allows you to select the file you want to open.

Can I Speed Things Up?

There are a number of reasons why things are sometimes slow in Mosaic. The major points were described in Unit 3: Mosaic Introduction. Unfortunately, they are not items over which you have any control. However, there is one thing you can do that will help speed things up some.

When Mosaic is downloading information, it first loads the text that will appear on the screen, and then loads the in-line images, the pictures, drawings, etc., that may be used in the document. In general, the text will not be very
long, but the images can be. For this reason, Mosaic has an option that disables loading the images. This option is under the Options menu and is **Auto-Load Images**. Mosaic defaults to automatically loading all the images along with the document. If you select this item, the check-mark will disappear. Now, when you go to a site, the text will be downloaded, but the images will be replaced by a substitute image symbol (place-holder).

There are two different place-holder symbols. The first is ![image placeholder](image), a place-holder for an image only. To download the image, just click on this symbol. The second symbol is ![image and link placeholder](image), a place-holder for an image that is also a link. To get the image, you click on the lower part of the symbol; to follow the link instead, click on the arrow.

**Stopping a Transfer**

You may end up at a site that takes too long to load the information. You can stop the transfer without waiting for it to complete by clicking on the Mosaic World symbol, ![Mosaic World](image), at the top of the screen.

**Capturing Files**

You will probably find some interesting items along the way that you would like to keep around, a favorite image, video clip, etc.

From within Mosaic, the Options menu has an item called Load to Disk. When you select this, and click on a link, Mosaic will start the download, then bring up a save dialog box (see **Saving Files**: in Unit 2: Using Simple Text if you are not sure how to save files) to save the file. When naming, use the suffix that Mosaic suggests. The suffix is not needed by the Mac, but is useful should you decide you want to use the item in a Mosaic document of your own. Mosaic uses the suffix to determine what type of item it is transferring.

If the item you want to keep is open inside one of the Helper applications, you can usually save the item from the Helper application. Mac applications that support saving files have a **Save As...** item in the File menu.
Unit 9: Designing Mosaic Documents

Now that you have had a chance to explore the Internet and see what types of things Mosaic is capable of doing, it is time to try your own hand at creating a Mosaic document, or series of documents. The next unit will talk about the mechanics of how to do that, but first you should start thinking about the possibilities in Mosaic and what you might like to do.

A Brilliant Idea!

Yes, that’s what you need, a brilliant idea! We’ll give you a couple of possible ideas on things that you could use to write a Mosaic document about. Then you are on your own. The only requirement is that the document you create must be for all the people in your group.

One possibility is to design a document about each person in your group. You can put in information about yourselves, others in your families, friends, pets, schools, teachers, etc. Each of these can be an item on your main Mosaic page, and by clicking on a particular one, the user will be taken to the page that describes that topic.

Or, instead of listing everything on the main page, you could have separate pages for each category. For example, one item on the main page might be “Jobs”. When that item is clicked, the user goes to a page that lists each job. By clicking on a particular job, the user goes to a third page that describes that job. For example,

Whether to make a topic a separate page usually depends on how much information you have for that topic. If there is a lot of information, or if there
are images you want to include on the page, it is a good plan to make a separate page. If there is only a small amount of information for each item, the items can all go on the same page.

**Fanciful Dreams:**

You do not have to write about real things. You could make up people or places and describe those in your document. Describe your dream house, with a different page for each room. Write about your favorite movies or TV shows (or stars) with a separate page for each. Or, group them into categories: favorite Westerns on one page, best horror films on another.

**Adventuring:**

You can make the Mosaic documents into a puzzle to be solved. You can use a question to determine what page to go to next. The user is presented with a multiple choice question. The right answer leads to the next level of the puzzle, while a wrong answer leads in a circle back to the starting point, or perhaps to nowhere at all! Think of it as, “Where in the Net is Carmen San Diego?”

**Including Things:**

You can put images, video clips, etc., into your document. Items that are available off the “Capers Home Page” can be used, and you should also include items that you have found from elsewhere during your Internet explorations. We will also have available photos of everyone that can be used in Mosaic. In addition, there are some drawing programs available if you would like to try your hand at making a map, picture, etc. to include.

**Where to Go From Here:**

**Unit 10: Writing Mosaic Documents** talks about the basics of HTML, the language used to write documents that Mosaic can display. It covers most of the language and points out where to look in the help files for additional information. There are also a number of examples in it for you to try as you read along. It is not necessary to do all of the unit before starting on your own Mosaic document. If you have an idea about what you would like to try, keep that in mind as you work through the unit. You can stop at any point and take what you have learned and use it in your own document.

The last point: Don’t be afraid to try something. Mosaic can do a lot of things. If you discover that you can’t do what you wanted, then that is part of the learning process! There may be a way around the difficulty; though, so
don’t be afraid to ask for help from the Instructor, TA’s, or others in the class. Finally, be creative. Use what you have learned by using Mosaic and what you have found by Net Surfing to create something that represents you; something that you, your friends, and your family will be impressed with.
Unit 10: Writing Mosaic Documents

Now that you have had a chance to use Mosaic and its Helper applications, you are ready to write your own Mosaic documents. To work on this unit, you will need to have the Mosaic application running on your Mac. You may find it useful to have two Mosaic windows open, one that you will use to view your document, and one open on the HTML Help page under the Hotlist menu. You will also need an editor or word processor running. You can use Simple Text (covered in Unit 2: Using Simple Text), Microsoft Word 5.1, or Microsoft Works 3.0. In what follows, we will assume you are using Simple Text.

Write, Save, View Cycle:

The basic idea in this lesson will be to make changes as suggested below using Simple Text. When you are ready to see how the changes will look in Mosaic, save the document in Simple Text, then switch to Mosaic (by selecting it from the Application menu) and open the document in Mosaic, using the command Open Local from the File menu. If it does not look like what you wanted it to appear, then switch back to Simple Text, make the needed changes or additions, and save the document. Switch back to Mosaic and select Reload from the File menu to view it.

The example file used in this unit is only for the purpose of explanation. You are encourage to use your own ideas, or examples from other Mosaic documents.

HyperText Markup Language(HTML):

Mosaic reads HTML documents. HTML (HyperText Markup Language) is a set of tags that are added to a text document. The tags describe the formatting to use for different parts of the document, and can provide links to other sections of the same document, to other HTML documents, and to other non-HTML items such as images.

Basic Formatting:

Mosaic ignores the way you format most things in Simple Text, but provides “tags” for you to use in formatting.

First, we need some text to work on. You can type some text into a Simple Text file to see how Mosaic displays your text when no tags are used. You can type whatever you like, or you can load the file called “D-Day.html” which you will find in the Capers folder. In what follows, I will suggest making
changes to the D-Day file, but you can make the same changes to your own file! After each change to the document (the D-Day.html, or your own file) save the document. (For your own file, use an appropriate name with the "html" on the end.)

To view the file in Mosaic use the Open Local command from the File menu, and select either your file or the D-Day.html file. The first thing you will notice is that Mosaic runs the text together, rather than separating it onto different lines!

Headings:

HTML supports six levels of headings, named H1 through H6. These are used to highlight different parts of the file. Change the first line in the D-Day.html file by adding the tags <H1> and </H1> at the beginning and end of the line. It should look like:

<H1>D-Day: June 6, 1944</H1>

The tag <H1> marks the start of the heading, and </H1> marks the end of the heading. Save the file, switch to Mosaic, and use Reload from the File menu to view the changes.

Try changing some other lines to be different heading. For example, you can try adding two other headings by changing lines in the D-Day.html file to:

<H2>Troops land on five beaches:</H2>
<H3>Three airborne divisions land in largest paratroop operation in history.</H3>

Try adding different heading tags to your Simple Text file to see what you get. Save the file and look at it again using Mosaic.

Paragraphs:

Inserting <P> after some text causes the text to be a new paragraph. For example, try adding <P> in the D-Day.html file, then save and look at the results in Mosaic:

British, Canadian, and US forces invade France!<P>
The Liberation of France from the Nazis has begun!<P>
Title:

You may have noticed that the title bar of Mosaic, when you opened your file, used the same name that you used when you saved the file. Rather than using the file name, you can tell Mosaic what title to use with the <TITLE> tag. For example, try adding the following line to the D-Day.html file:

```
<TITLE> D-Day News Story </TITLE>
```

Normally, this line will be the first line in the file; although, you can put it anywhere. The <TITLE> tag tells Mosaic to use this as the title of the Mosaic window when the file is opened. Normally, you would make the title only a few words long (but, what does Mosaic do if you put a really long title in?).

Text Styles:

HTML supports several styles of print. You have already seen how the use of headings changes the size of the print used for the headings. You can also get:

- **bold** print by surrounding the text with the tags `<B>` and `</B>`,
- *italic* print by using the tags `<I>` and `</I>`, and
- **underline** text by using the tags `<U>` and `</U>`.

These tags can be combined. For example, the following uses both underlining and bold in overlapping parts. You can make the changes shown below in the D-Day.html file:

```
Thousands of Allied troops attack <B>five</B> beaches along the Normandy coastline in <U>northwest <B>France.</B></U> Heavy German opposition is slowly overcome as the troops fight their way onto the beach and begin <I>pushing inland.</I><P>
```

Save the file and view it in Mosaic. Try adding more formatting to the file!

Links and Anchors:

HTML documents can contain links that refer to other places in the same document, to other documents, and to documents on other computers. There is one tag that controls this ability: `<A>`, called the anchor tag. The anchor tag has more options than the tags we have been looking at until now, and it takes on somewhat different forms depending on where the link points.

Links are very useful in creating Mosaic documents. First, links allow the user to obtain the latest information. For example, if you create a Mosaic document that includes the “latest news”, you can link to the CNN news
server. When the CNN site updates the news, you will automatically get the updated news when you follow the link. Second, using a link saves space; for example, if you want to provide many gif image files, you will likely run out of disk space.

Use the following to create a link to a file:

```html
<A HREF = "name of file to link"> description </A>
```

where `name of file to link` is the file to link to, and `description` is some text describing the link.

For example, there is another HTML document on your disk named “Divisions.html”. To create a link in “D-Day.html” that points to “Divisions.html”, you would type (at the end, or anywhere else in the file you wish):

```html
<A HREF = "Divisions.html"> A list of divisions participating in the landing </A>
```

The phrase

```html
<A HREF = "Divisions.html">
```

actually constitutes the entire tag. The text between the starting anchor tag and the ending anchor tag, `</A>`, will be highlighted in blue on the Mosaic window. The user of the “D-Day.html” document can then click anywhere in the highlighted text, and Mosaic will load the document “Divisions.html”. There is a similar anchor tag in the “Divisions.html” file that points back to the “D-Day.html” file; you can click it to return to the D-Day page.

File Locations:

A note is in order here about where these files are actually located on the disk of your Mac. In the example above, I was assuming that the two files “D-Day.html” and “Divisions.html” were located in the same folder. If the file you want to link to is located inside another folder, you have to include the folder name as well as the file name. For example, if “D-Day.html” and a folder named “D-Day Stuff” are together:

![Folder Structure](image)

and “D-Day Stuff” contains the file “Divisions.html”, then the correct link
would be:

```
<A HREF = "D-Day Stuff/Divisions.html"> A list of divisions participating in the landing </A>
```

The slash, /, in the name in quotes tells Mosaic to look inside the folder “D-Day Stuff” to find the file “Divisions.html”. This is known as a relative reference, since you are telling Mosaic to start in the same place it found “D-Day.html” and look for the folder “D-Day Stuff”.

It is also possible to use an absolute reference. For this, you specify the name of the disk drive. For example:

```
<A HREF = "/Poodle-228/Capers/D-Day Stuff/Divisions.html"> A list of divisions participating in the landing </A>
```

Mosaic will recognize the difference between a relative and an absolute reference by whether it starts with a slash, /, or not. For the absolute reference, you have to list the disk drive and each folder that must be opened to find the file.

**URL:**

You have seen URL’s in **Unit 8: Net Surfing** when navigating the Internet. They are used in HTML documents as well to establish a link to a Mosaic document on another computer. To take a quick example, if you wanted to establish a link in your document to the “Capers Home Page” that is on the computer schooner, you would use the following:

```
<A HREF = "http://schooner:5605/Capers.html"> The Capers Home Page </A>
```

To understand what is being referred to here, we have to look at each part:

- **http:** The type of connection that will be formed. In this case, http refers to the HyperText Transfer Protocol that Mosaic uses to simplify the transfer of data between machines.
- **schooner** The name of the computer containing the file, picture, etc., that we are looking for.
- **5605** The port number on the computer that Mosaic should use. A port is a communication connection on a computer and there can be many of them for each computer.
- **Capers.html** The file we want to load. In this case, an HTML document.
As you can see, URL’s tend to be quite long. See if you can figure out alternatives to typing in the URL each time. Hint: URL information is available in the URL box or Hotlist Interface menu.

Links to the Middle of Documents:

The assumption so far has been, that a link will always point to another file. However, it does not have to. For example, look at the HTML Help from the Hotlist menu. When you select one of the links, you will jump to another point in the same document. Verify that this is the case.

To do the same thing in your document requires two uses of the anchor tag. In fact, this is why the tag is named “anchor”. First, go to the place you want the link to point to. For example, in the file “D-Day.html”, suppose we add a section that talks about beaches. We might write:

```html
<H2> <A NAME = "Beach List"> Troops land on five beaches: </A> </H2>

Sword
Gold
Juno
Utah
Omaha
```

The use of the word NAME in each case will tell Mosaic this is an anchor that other places may point to. Now, to provide the user with the opportunity to jump directly to the section on the beaches, find the section of D-Day.html that says:

```
The invasion is composed of landings by airborne troops and along five beaches.
```

Change this by adding an anchor tag around the phrase “five beaches”:

```
The invasion is composed of landings by airborne troops and along <A HREF = "#Beach List">five beaches.</A>
```

Now the user can select this link and go directly to the Beach List part of the document. The pound sign, #, indicates that the reference is to a specific anchor in the same file. The phrase “five beaches” should appear in blue in Mosaic when you Reload the document.

Links can be added that point to anchors inside other files. To illustrate
this, add the following line somewhere in your HTML document:

```
<A HREF = "http://schooner:5605/Capers.html#Folks"> Capers Staff </A> <P>
```

This is a reference to the “Capers Home Page” again, but this time to a particular section within it that contains the list of the staff for Capers.

**Links to Other Types of Documents:**

As you have noticed in using Mosaic, it is not necessary to link only to other HTML documents. You can also provide links to such items as images, sounds, etc. The method is the same as linking to an HTML document, for example, to provide a link to the Horsehead nebula image that is on your disk, you would use:

```
<A HREF = "Local Home page/horsehead.gif">
Horsehead Nebula </A>
```

The key point lies in the suffix used in specifying the file, in particular the part that follows the period. In the example above, the use of “.gif” on the end of the file name tells Mosaic this is not an HTML document, but a gif image. When Mosaic has transferred the file, it will then start the appropriate helper application, JPEGView in this case.

As an example, you can access any of the images on the “Capers Home Page”, or the other image pages it points to. The reference:

```
<A HREF = "http://schooner:5605/Animal-picts/gif/Animal-picts/brown-bears.jpg"> two brown bears </A>
```

will create a link to a jpeg image of a pair of brown bears.

**In-lining Images:**

Mosaic is able to display in-line images, that is, images that appear in the text. It can display two types of in-line images, those with the extensions .gif or .xbm. In general, these are small images; although, they do not have to be. The only drawback to large images is the time it takes Mosaic to transfer the image. To save transfer time, most places put a small in-line image in the document and a link to the large version. This allows users to decide if they want to take the time to download the large image or not.

Use the following to include an in-line image:

```
<IMG SRC = "imagefile">description</P>
```
In the above, *imagefile* is the name of the image file that will be displayed, and description is a phrase that describes the image. For example:

```html
<IMG SRC = "sm-tiger.gif"> a tiger drawing <P>
```

will load the small tiger drawing into the Mosaic document.

One additional note, you can add the phrase ALIGN to IMG. For example, you could change the above tiger example to:

```html
<IMG ALIGN = TOP SRC = "sm-tiger.gif"> a tiger drawing <P>
```

Try using bottom alignment, or no alignment to see what the default is.

**Acquiring Small Images:**

You do need to give some thought to where the image will come from. If it is from a site that has a slow connection, it would be better to download the image into your Mac.

Downloading an in-lined image used in another Mosaic document is done by first going to the Mosaic page you want to use. For example, if you want to download a small animal image from the Capers Home Page, or one of the animal pictures pages, you would first go to the page. Then:

- Turn off **Auto-Load Images**
- Select **Reload**
- Select **Load to Disk**

- Click on the lower part of the 📥 symbol for the image you want
- When the save dialog box appears, tell Mosaic where to save the image.
  - Use a “.gif” suffix for the name.

When complete, Mosaic will report an “Error: Image Load Failed” message! That simply means it is not displaying the image since it was saved to a disk file instead. You will, however, be able to open the image from JPEGView if you want to view it.

**More Formatting:**

**Lists:**

You can specify a list of items using HTML. There are two types of lists, ordered (or numbered) and unordered.

To create an ordered or numbered list, you use the `<OL>` tag to start the
list, and the \texttt{</OL>} tag to end the list. Each item in the list is identified by a list element tag, \texttt{<LI>}. For example, in the “D-Day.html” file, you can change the beaches section to:

\begin{verbatim}
<H2> <A NAME = "Beach List"> Troops land on five beaches:</A> </H2>
<OL>
  <LI>Sword
  <LI>Gold
  <LI>Juno
  <LI>Utah
  <LI>Omaha
</OL>
\end{verbatim}

You can include paragraphs within list elements. Just use the paragraph tag \texttt{<P>} to mark the end of each paragraph.

Unordered lists are done in the same way as ordered lists, except you use the tag \texttt{<UL>} to start the list, and the tag \texttt{</UL>} to end the list. Try making the list of airborne divisions in “D-Day.html” an unordered list!

There is one more type of list in HTML to describe. It is called a Descriptive List, and uses the tag \texttt{<DL>} to start the list, and the tag \texttt{</DL>} to end the list. Within the list, there are two types of items: a Description Title (tag \texttt{<DT>}) and a Description Description (tag \texttt{<DD>}). The title generally is short, and will be displayed on a line by itself, and the description can be arbitrarily long and will start on the line below the title. For example, try the following (or something similar):

\begin{verbatim}
<DL>
  <DT> Hamlet
  <DD> A tragedy where Hamlet is asked to avenge his Father's murder, but ends up harming others in the process.
  <DT> A Midsummer's Night Dream
  <DD> A comedy about spirits in the woods.
</DL>
\end{verbatim}

You also can put lists inside other lists. Try doing this.
Preformatted Text:

To force Mosaic to format the text exactly the way you entered it in Simple Text, enclose the text with <PRE> and </PRE> tags. Mosaic will still recognize other tags inside the preformatted text, so you can still put a list in, for example, or a link. Give this a try.
Glossary

bandwidth..........A measure of the amount of information that can flow through a communications channel at the same time.

cache................Local storage for information so the computer does not have to acquire it again. Used by Mosaic to remember information already acquired during the current session.

click................A press and release of the mouse button.

client...............One half of client-server. The computer that requests the information from the server.

crop...................The process of selecting a portion of an image and removing the rest of the image.

desktop ...............On the Macintosh, the metaphor of the screen. Pretend the screen is horizontal, and the items on the screen are folders, sheets of paper, tablets, etc., that are placed on different places about the top of a desk.

double-click........Two clicks of the mouse button in quick succession.

drag...................Moving the mouse while holding the mouse button down.

font ...................A collection of all the characters the Mac can print, all done in a similar style and in the same size. For example, this is Times 14 point font.

gif ......................A compression technique for computer storage of images. Does not lose any information, so the original quality of the image is still present. However, it is limited to 256 colors.

grayscale..........Using shades of gray to present a picture in black-and-white. This is the way black-and-white images are shown on the computer screen, and can also be used to turn a color image into a black-and-white image.

HTML ..............HyperText Markup Language (also used in lower case – html).

icon...................A (usually small) graphic used on the Macintosh to represent a data file, folder, application, disk drive, etc. When spelled with a capital ‘I’, Icon is a programming language specially designed to process text rather than numbers. (Had to mention that since Icon just happens to have been developed here in the Computer Science department.)
interpolation ...... A process of approximating a unknown data value that lies in-between two known data values.

jpeg, jpg ............ A compression technique for computer storage of images. The technique is very good at saving space, resulting in less disk usage to remember the image, and less bandwidth to transmit the image, and can handle millions of colors. Has the drawback that the technique losses some information; thus, the quality of the image may not be as good as the original image.

Mosaic ............... A tool for searching out information on the Internet. Computers which run Mosaic servers can supply information on request to Mosaic clients. Can handle text, images in several formats, video clips, and sound.

NCSA ................. National Center for Supercomputing Applications. Located at The University of Illinois at Urbana-Champaign, it is funded by the National Science Foundation, the state of Illinois, the University of Illinois, and corporate partners. It’s main purpose is to support computational science — the ability to recreate or simulate on a computer natural phenomena. In many cases, such phenomena cannot be investigated in the laboratory or fully evaluated theoretically due to such constraints as safety, cost, speed, or time.

pixel .................. A dot on a computer screen. For example, the Macintosh displays used for Capers have 640 pixels across and 480 pixels down, for a total of 307,200 pixels.

point .................. a unit of about 1/72 inch used to measure the size of type; larger point sizes mean larger type. For example, this is Times 14 point font.

pop-up menu ...... A list of items, or commands, in a Macintosh application that are grouped together and may appear at different places on the Macintosh screen. Characterized by a rectangle with a small arrowhead on the right side.

pull down menu . A list of items, or commands, in a Macintosh application that are grouped together and appear under one of the menu choices across the menu bar at the top of the screen.

scaling............... When working with a picture, the reduction of the width and height according to some factor. For example, scaling by 50% would reduce the width by half, and the height by half, for a result that is one-fourth as large. Can be done
disproportionately. For example, the width can be reduced by half while the height remains the same.

server ..................One half of client-server. The computer that supplies the information request by the client.

wrap-around .......A technique used by text editors and word processors that allows the user to keep typing and not worry about the right edge of each line. The program will automatically go to the next line in between words.

URL..................Uniform Resource Locator (also used in lower case — url).